Yoto

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
UK, EU & CA websites are down
Resolved·Full outage

The issue affecting our websites has been fully resolved. Services are now operating as expected. We sincerely apologise for any disruption this may have caused and thank you for your understanding. If you encounter any additional problems, please reach out to our Customer Happiness team at https://support.yotoplay.com.

Mon, May 11, 2026, 09:31 AM
(1 month ago)
·
Affected components
May 10, 2026, 07:57 AM
08:10 AM
Updates

Resolved

The issue affecting our websites has been fully resolved. Services are now operating as expected. We sincerely apologise for any disruption this may have caused and thank you for your understanding. If you encounter any additional problems, please reach out to our Customer Happiness team at https://support.yotoplay.com.

Mon, May 11, 2026, 09:31 AM

Monitoring

The issue affecting our websites has been resolved, and the service has returned to normal. Our team is closely monitoring the situation to ensure no further disruptions occur. If you experience any lingering issues, please contact our Customer Happiness team at https://support.yotoplay.com.

Sun, May 10, 2026, 08:10 AM(1 day earlier)

Investigating

We are currently investigating an issue affecting our UK, EU and CA websites. Customers may not be able to access the Yoto websites in these regions. Our team is working to identify the cause, and we will provide an update as soon as more information becomes available. Thank you for your patience.

Sun, May 10, 2026, 07:57 AM(13 minutes earlier)