Yoto web stores are slow or unable to load
Resolved·Degraded performance

The issue affecting our website has been fully resolved. Services are now operating as expected. We sincerely apologize for any disruption this may have caused and thank you for your understanding. If you encounter any additional problems, please reach out to our Customer Happiness team at https://support.yotoplay.com.

Fri, Mar 21, 2025, 03:29 PM
(2 months ago)
·
Affected components
Updates

Resolved

The issue affecting our website has been fully resolved. Services are now operating as expected. We sincerely apologize for any disruption this may have caused and thank you for your understanding. If you encounter any additional problems, please reach out to our Customer Happiness team at https://support.yotoplay.com.

Fri, Mar 21, 2025, 03:29 PM

Resolved

The issue affecting our [service/system] has been fully resolved. Services are now operating as expected. We sincerely apologize for any disruption this may have caused and thank you for your understanding. If you encounter any additional problems, please reach out to our Customer Happiness team at https://support.yotoplay.com.

Fri, Mar 21, 2025, 03:28 PM

Investigating

We are currently investigating an issue affecting our [service/system]. Customers may experience [brief description of the impact]. Our team is working to identify the cause, and we will provide an update as soon as more information becomes available. Thank you for your patience.

Fri, Mar 21, 2025, 03:28 PM

Investigating

Due to an ongoing issue with our hosting provider, some users may either not be able to access the web stores, or get a slow browsing experience if they can. Our team is working to identify the cause, and we will provide an update as soon as more information becomes available. Thank you for your patience.

Fri, Mar 21, 2025, 03:02 PM(25 minutes earlier)